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1.UVOD 

Cilj ovog završnog rada bila je usporedba visina s topografske karte Sveti Juraj mjerila 

1:25 000 s visinama iz satelitske misije SRTM. Ukratko će se dati opis metodologije 

korištene u izradi završnog rada. Opisan je softver QGIS, prostorna analiza i prostorna 

interpolacija koja se koristili pri izradi završnog rada. 

 Prvo će se opisati korišteni softver QGIS i koraci pri izradi digitalnog modela terena, 

prostorna analiza, prostorna interpolacija i TIN interpolacija. Zatim će se kronološki 

opisati tijek izrade 3D modela i izračun razlika u visinama. Započet će se vektorizacijom 

slojnica topografske karte koje će se interpolirati TIN metodom kako bi se dobio digitalni 

model. Posljednji korak je izračun razlika u visinama između dva piksela na istim 

pozicijama na digitalnim modelima. 

Na kraju će se dati zaključak o dobivenim rezultatima i metodama pri usporedbi visina s 

topografske karte Sveti Juraj i modela dobivenog satelitskom misijom SRTM. 

 

2.  OPIS METODOLOGIJE 

     U ovom poglavlju ukratko će se opisati QGIS softver koji se koristio u izradi digitalnog 

modela terena te princip rada na njemu. Također će se objasniti prostorna analiza, 

prostorna interpolacija i TIN interpolacija. 

 

       2.1. QGIS 

QGIS (Quantum GIS) je geografski informacijski sustav (GIS) koji je ujedno besplatni 

softver otvorenog koda FOSS (eng. Free Open Source Software). To znači da se 

omogućuje korisniku pravo korištenja softvera u bilo koju svrhu, proučavanje na koji način 

softver radi i njegovo modificiranje te omogućavanje unaprjeđenja i poboljšanja softvera te 

ustupanje poboljšanja ostalim korisnicima. (GIS lounge, 2020.) 

      Softver je službeni projekt organizacije OSGeo (eng. Open Source Geospatial 

Foundation). Koristi se na Linux, UNIX, Mac OSX, Windows i Android operacijskim 

sustavima, a podržava brojne vektorske, rasterske formate i formate baznih podataka i 

funkcionalnosti. (QGIS, 2020.)  

      QGIS nudi mnogo GIS funkcionalnosti, od kojih su neke omogućene samom 

instalacijom softvera dok su ostale dostupne instalacijom dodataka unutar samog softvera. 

Postoji šest općih kategorija svojstava softvera, a to su (QGIS Features, 2020.): 
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1) Pregled podataka: Moguće je pregledati kombinacije vektorskih i rasterskih  

podataka (u 2D ili 3D) u različitim formatima i kombinacijama bez pretvorbe u 

zadani ili zajednički format.  

2) Istraživanje podataka i izrada karte: Softver omogućuje izradu karte i interaktivno 

istraživanje prostornih podataka pomoću grafičkog sučelja ili GUI (eng. Graphical 

user interface). Mnoštvo korisnih alata dostupno je na grafičkom sučelju koje 

uključuje: Identify/select features koji omogućuje identificiranje i označavanje 

pojedinih podataka, Edit/view/search attributes- je alat za uređivanje, pregled i 

pretragu atributa, Support for saving and restoring projects omogućuje spremanje i 

obnavljanje projekta, itd. 

3) Stvaranje, uređivanje, upravljanje i izvoz podataka: Softver omogućuje stvaranje, 

uređivanje, upravljanje i izvoz vektorskih i rasterskih slojeva u nekoliko formata. 

QGIS nudi alate za digitalizaciju vektora, potporu za vizualizaciju i uređivanje 

OpenStreetMap podataka, GPS alate za uvoz/izvoz GPX formata i pretvorbu drugih 

GPS formata u GPX ili ih direktno skinuti/učitati u GPS uređaj, itd. 

4) Analiziranje podataka: QGIS trenutno omogućuje vektorsku analizu, prostornu 

analizu, uzorkovanje, geoprocesiranje i alate za upravljanje bazom podataka. 

5)  Objavljivanje karata na internetu: QGIS se može koristiti kao WMS, WMTS, 

WMS-C ili WFS i WFS-T klijent i kao WMS, WCS ili WFS poslužitelj. Uz to, 

moguće je objaviti podatke na internetu korištenjem webservera sa instaliranim 

QGIS Serverom,UMN MapServerom ili GeoServerom. 

6) Proširivanje funkcionalnosti dodacima: QGIS se može prilagoditi različitim 

potrebama korisnika instalacijom različitih dodataka te stvaranju novih dodataka 

korištenjem programskih jezika Python ili C++. 

 

       2.2. Prostorna analiza 

       Prostorna analiza je proces manipulacije prostornim informacijama za dobivanje 

novog značenja i informacija iz originalnih podataka. Obično se prostorna analiza provodi 

u GIS-u koji nudi alate prostorne analize za izračunavanje statističkih značajki i 

provođenje geoprocesnih aktivnosti kao interpolacije podataka. (Osnove GIS-a,2020). 
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  2.3. Prostorna interpolacija 

      Prostorna interpolacija je postupak korištenja točaka s poznatim vrijednostima za 

procjenu vrijednosti u drugim nepoznatim točkama. Postoje mnoge metode interpolacije 

poput inverzne udaljenosti (IDW) i mreže nepravilnih trokuta (TIN). (QGIS Interpolation, 

2020.) 

      U izradi digitalnog modela korištena je metoda TIN interpolacije slojnica sa 

topografske karte. 

 

       2.4. TIN interpolacija 

       TIN (Triangulated Irregular Network) interpolacija ili mreža nepravilnih trokuta je alat 

u GIS-u koji pokušava stvoriti površinu formiranu trokutima najbližih susjednih točaka. 

Uobičajeni algoritam TIN-a naziva se Delaunayeva triangulacija (Slika 2-1). Da bi se to 

učinilo, stvaraju se krugovi oko odabranih točaka uzorka i njihovi presjeci spojeni su na 

mrežu koja se ne preklapa i tvore što je moguće kompaktnije trokute. Glavni nedostatak 

TIN interpolacije je taj što površine nisu glatke i mogu dati nazubljen izgled. To je 

uzrokovano povremenim padinama na rubovima trokuta i uzorcima podataka. (QGIS 

Interpolation, 2020.) 

  

 

Slika 2-1 Delaunayeva triangulacija(QGIS Interpolation, 2020.) 
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3.  OBRADA PODATAKA 

     3.1. Učitavanje rasterskih podataka 

Rasterski podaci u GIS-u su matrice diskretnih piksela koje predstavljaju značajke na, 

iznad ili ispod zemljine površine. Svaki piksel u rasterskoj mreži je jednake veličine, a 

pikseli su obično pravokutni (u QGIS-u će uvijek biti pravokutni). Uobičajeni rasterski 

setovi podataka uključuju podatke daljinskog snimanja, poput zračne fotografije ili 

satelitske slike i modelirane podatke, kao što je matrica nadmorske visine. Za razliku od 

vektorskih podataka, rasterski podaci nemaju pridruženi zapis baze podataka za svaki 

piksel. Geokodiranjem se svakom pikselu pridružuje prostorna koordinata. QGIS koristi 

informacije o georeferenciji unutar rasterskog sloja (npr.GeoTiff) ili u odgovarajućoj 

projekcijskoj datoteci za ispravno prikazivanje podataka. (QGIS Raster Data, 2020.) 

   Rasterski podaci se u QGIS-u učitavaju odabirom opcije na izborniku Layer>Add 

layer>Add raster layer. U ovom slučaju početni rasterski podatak je georeferencirana 

topografska karta Sveti Juraj u mjerilu 1:25000. (Slika 3-1) 

 

Slika 3-1 Georeferencirana topografska karta u mjerilu 1:25 000 Svetog Juraja 

 

      3.2. Vektorizacija slojnica 

     Prvi korak pri izradi 3D modela je vektorizacija slojnica. Vektorizacija rasterskog 

podatka u QGIS-u radi se pomoću opcije Layer > Create Layer > New SpatiaLite 

Layergdje se odabire linija kao geometrijski lik, dodaje atribut visina, imenuje te spremi 

(Slika 3-2).  
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Slika 3-2Stvaranje New SpatiaLite Layera 

 Nakon toga se uključi opcija uređivanje (Toggle editing) i odabire se opcija AddLine 

Feature te sa klikom miša iscrtavamo slojnice. Završetak iscrtavanja se izvodi desnim 

klikom miša nakon čega se otvara prozor u koji upisujemo iznos atributa visine pojedine 

slojnice (Slika 3-3). 

 

 

 

 

 

 

 

 

Slika 3-3Upisivanje atributa slojnica 
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  3.3. Interpolacija slojnica 

   Prilikom vektorizacije slojnica dogodilo se da pojedine slojnice nestaju na karti, odnosno 

bivaju isprekidane ili ih nešto preklapa. Zbog toga provodi se interpolacija, a u ovom 

slučaju koristit ćemo TIN interpolaciju odabirom na izborniku Processing > Toolbox. 

Klikom miša na Toolbox otvara nam se prozor na desnoj strani QGIS sučelja gdje 

odabiremo Interpolation > TIN interpolation. (Slika 3-4) 

 

 

Slika 3-4Odabir TIN interpolacije sa sučelja 

 

    Otvara nam se prozor s mogućnošću odabira parametara interpolacije. Odabire se 

vektorski sloj slojnice, visina kao interpolacijski atribut preko kojeg se provodi 

interpolacija, interpolacijska metoda, opseg interpolacije, veličina izlaznog rastera i mjesto 

spremanja dobivene interpolacije u .tif formatu. Nakon odabira zadanih parametara provodi 

se interpolacija i dobivamo TIN model terena Sv. Juraj. (Slika 3-5, slika 3-6) 
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Slika 3-5Odabir parametara TIN interpolacije 

Slika 3-6TIN model terena Sv.Juraj 

    Zato što interpolacija ne daje točne rezultate izvan područja skupljanja podataka 

moramo očistiti površinu granicom terena. Na izborniku odabiremo Raster > Extraction > 

Clip raster by mask layer. Otvara se prozor na kojem odabiremo kao ulazni layer dobiven 

TIN model terena, odabiremo granicu terena, naziv izlazne datoteke tin_model_htrs96_clip 

i na kraju pokrenemo skriptu. Na dobivenom prikazu su svi podaci izvan granica terena 

definirani kao no data podaci pa se ne prikazuju.(Slika 3-7) 
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Slika 3-7TIN model terena unutar područja analize 

 

 

   3.4. Stiliziranje 

   Dobiveni digitalni model terena stilizirat će se kako bi poboljšali vizualizaciju samog 

terena. Preko opcije Propertise sloja odabere se Symbology unutar kojeg se postave sve 

opcije kao na slici 3-8. Rezultat tako odabranih opcija vidi se na slici 3-9 koja prikazuje 

digitalan model terena za područje Sv. Jurja.  
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Slika 3-8Odabir svojstava sloja 

Slika 3-9Model terena nakon stiliziranja 
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    Dobivenoj karti možemo dodati i slojni prikaz reljefa odabirom na izborniku Raster > 

Extraction > Contour . Otvara se prozor u kojem za ulazni sloj odabiremo digitalnimodel 

terena Sv. Jurja. Kod opcije Intercal between contour line definiramo ekvidistancu između 

slojnica,u ovom slučaju 10 metara i rezultat spremamo u direktorij gdje smo prethodno 

spremali podatke i pritisnemo Run. (Slika 3-10) 

 

Slika 3-10Dodavanje slojnog prikaza reljefa na opciji Contour 

 

    Rezultat je prikaz slojnica kojima možemo dodati vrijednost koristeći se Labels 

opcijama do kojih se dolazi klikom desne tipke miša na Slojnice i odabire se Properties. 

Sve postavke postavimo kao na slici dolje te se dobiva završni rezultat stiliziranja.(Slika 3-

11, slika 3-12) 
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Slika 3-11Dodavanje vrijednosti slojnica pod labels u svojstvima sloja 

 

Slika 3-12Završni rezultat stiliziranja terena 
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  3.5. Obrada satelitske snimke trena 

Shuttle Radar Topography Mission (SRTM) međunarodno je istraživačko djelo koje je 

dobilo digitalne modele nadmorske visine na globalnoj skali od 56o J do 60o S kako bi se 

stvorila najpotpunija digitalna topografska baza podataka visoke rezolucije Zemlje. (SRTM 

Wiki, 2020.) 

     Kako bi se izvršila misija koristio se radar sa sintetičkim otvorom blende i 

interferometrija. Do rujna 2014., najbolji raspoloživi SRTM digitalni model uzvišenja 

(DEM- Digital Elevation Model) bio je razlučivost od 90 metara. Sada je 30-metarska (1 

lučna sekunda) rezolucija SRTM javno dostupna na USGS Earth Exploreru za veći dio 

svijeta. Ova poboljšana verzija predstavlja punu razlučivost izvornih mjerenja. Globalni 

digitalni model nadmorske visine ima prostornu rezoluciju od oko  30 metara koja prekriva 

veći dio svijeta s apsolutnom vertikalnom točnošću visine manjom od 16 metara. Nabolje 

mjesto za preuzimanje SRTM digitalnih modela je putem USGS Earth Explorera u samo 

nekoliko koraka: odabere se područje interesa, na kartici skupova podataka odabere se 

Digital Elevation>SRTM>SRTM 1-ArcSecond Global te se doda u košaricu i preuzme. Za 

podatkovne proizvode SRTM ima dvije razine obrade. Prvo, praznina ispunjena DEM 

ispunjava null vrijednosti tamo gdje ne zadovoljava standardne specifikacije. I drugo, non-

void verzija sadrži praznine i nisu popunjene pomoću interpolacije i drugih izvora 

nadmorske visine. Nosivost SRTM-a bila je opremljena na Space Shuttle Endeavoru. 

Topografska misija radara Shuttle (SRTM) koristi inSAR koji mjeri elevaciju Zemlje s 

dvije antene. Koristeći dvije radarske antene i jedan prolaz, generirao je digitalni model 

nadmorske visine koristeći interferometrijski radar sa sintetičkim otvorom (inSAR). 

Budući da se radar C pojasa bori s prodorom guste vegetacije, u jako pošumljenim 

područjima SRTM je preslikao vrh krošnje. (GIS Geography, 2020.) 

 Kako bismo dobili kartu razlika modela terena potreban nam je digitalni model terena Sv. 

Jurja dobiven pomoću satelitske misije SRTM u HTRS96 koordinatnom sustavu (Slika 3-

13). Visine na digitalnom modelu se mijenjaju od crne boje sa iznosom  0 metra preko 

sivih boja do bijele s iznosom  od 900 metara nadmorske visine.   
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Slika 3-13Digitalni model terena Sv.Juraj dobiven satelitskom misijom SRTM 

 

Dobiveni model srtm1_htrs96 zauzima šire područje od granice terena pa podatke šire od 

te granice treba očistiti. To ćemo napraviti kao u prethodnom koraku odabirem opcije na 

izborniku Raster > Extraction > Clip raster by mask layerkojim uklanjamo višak podataka 

izvan područja analize. Obrađeni model terena spremamo u mapu s prijašnjim podacima 

kao datoteku naziva srtm1_htrs96_clip. (Slika 3-14) 
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Slika 3-14Digitalni model terena na području analize 

 

    3.6. Izračun razlika u visini 

    Izračunat će se razlika između tin_model_htrs96_clip i srtm1_htrs96_clip. Za takvo 

računanje koristimo opciju na izborniku Raster > Raster Calculator. Nakon toga se otvara 

prozor sličan običnom kalkulatoru samo što ovdje odabiremo rastere i računske operacije 

koje s njima želimo napraviti (Slika 3-15). Te operacije se zatim izvode za svaki pojedini 

piksel iz jednog i drugog rastera. U ovom slučaju oduzimamo dva rastera, 

srtm1_htrs96_clip od tin_model_htrs96_clip. Pod opcijom Raster Calculator Expression 

upisuje se formula po kojoj se računa razlika i na kraju stisnemo OK.  
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Slika 3-15Raster Calculator 

  Po završetku izračuna stvara se novi raster razlika_srtm1_tinmodel koji nam prikazuje u 

kojem području je srtm1_htrs96_clip iznad, a gdje ispod plohe tin_model_htrs96_clip. 

(Slika 3-16) Dobiveni raster se ujedno može stilizirati kao i modeli dobiveni u prijašnjim 

koracima desnim klikom na layer i odabirom Properties gdje idemo u odjeljak Symbology. 

 

 

 

 

 

 

 

 

 

 

Slika 3-16Razlika u visini dvaju modela u pojedinim pikselima 
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4. ZAKLJUČAK 

U ovom završnom radu izvršena je usporedba visina s topografske karte Sveti Juraj u 

mjerilu 1:25000 i satelitske misije SRTM-a. Pri izradi digitalnog modela topografske karte 

korišten je softver QGIS kojim se provela vektorizacija slojnica pomoću kojih se izradio 

digitalni model terena korištenjem TIN interpolacije. U posljednjem dijelu proveden je 

izračun visinske razlike između digitalnog modela dobivenog TIN interpolacijom i 

digitalnog modela dobivenog pomoću satelitske misije SRTM. Dobiven je digitalni model 

koji prikazuje visinske razlike između dva modela. 

    Iz dobivenog digitalnog modela razlika u visinama zaključuje se kako dolazi do 

odstupanja u visinama između dva piksela na istim pozicijama dva digitalna modela. 

Indikator toga je dobiven završni model na kojem se uz legendu mogu vidjeti koliko iznose 

odstupanja na pojedinim pikselima. 

Ono što dovodi do ovakvih rezultata može biti pogreška pri radu na QGIS softveru, 

odnosno pogreška pri unosu podataka, odabira pojedinih parametara u izradi digitalnih 

modela ili nesavršenost algoritama koji vrše izradu digitalnog modela topografske karte. 

Greška koju sam primijetio pri izradi završnog rada je interpolacija slojnica s topografske 

karte gdje se pojedine slojnice pri interpolaciji interpretiraju kao ravne slojnice. Ovo 

dovodi do pogrešaka na digitalnom modelu što na kraju vodi do razlika u visini između 

dvaju modela. Ukoliko dolazi do takvih situacija može se poslužiti sa drugom vrstom 

interpolacije kao što je interpolacija inverzne udaljenosti (IDW). Pogreške se više mogu 

dogoditi kod digitalnih modela satelitske misije SRTM zato što pri snimanju signal ne 

dopire do zemlje na nekim dijelovima zbog utjecaja vegetacije ili zgrada u urbanim 

područjima. Radi takvih razloga satelitska misija SRTM se prvenstveno koristila u 

šumarstvu i računanju promjene volumena biomase. Podaci dobiveni satelitskom misijom 

SRTM datiraju iz 2014. godine te se smatraju zastrjelima zbog čega se danas podaci svakih 

nekoliko dana osvježuju pomoću sintetičkih radara. Zato digitalni modeli satelitske misije 

služe kao rezerva odnosno provjera nekoj drugoj metodi za izradu digitalnog modela. 

Pozitivna stvar kod QGIS softvera je što se konstantno može unaprijediti razvojem novih 

dodataka koji se mogu instalirati te ubuduće dati preciznije rezultate digitalnog modela. 
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